Problem
When you navigate to Genie from your workspace dashboard view, you only see a blank screen. When you try to click the +New button, you receive the following error message.
"error_code": "PERMISSION_DENIED",
"message": "Partner-powered AI features are disabled. Please contact your administrator.",
"details": [{<details>}]
The following image shows an additional message in the UI, “failed to create space,” along with the error message.
Cause
You have the setting Enforce data processing within workspace Geography for Designated Services enabled for the workspace in your account console.
Solution
- Navigate to Account console > Workspace > Security and compliance.
- Toggle off Enforce data processing within workspace Geography for Designated Services to disable the setting. The following image shows the setting within the workspace UI.
For more information, review the Curate an effective Genie space (AWS | Azure | GCP) documentation.