“Failed to create space” message when attempting to create new Genie space

Disable “Enforce data processing within workspace Geography for Designated Services” for the workspace from the account console.

Written by shashank.chaudhary

Last published at: July 1st, 2025

Problem

When you navigate to Genie from your workspace dashboard view, you only see a blank screen. When you try to click the +New button, you receive the following error message.  

"error_code": "PERMISSION_DENIED",
  "message": "Partner-powered AI features are disabled. Please contact your administrator.",
  "details": [{<details>}]

 

The following image shows an additional message in the UI, “failed to create space,” along with the error message.

 

Cause

You have the setting Enforce data processing within workspace Geography for Designated Services enabled for the workspace in your account console. 

 

Solution

  1. Navigate to Account console > Workspace > Security and compliance
  2. Toggle off Enforce data processing within workspace Geography for Designated Services to disable the setting. The following image shows the setting within the workspace UI.

 

 

For more information, review the Curate an effective Genie space (AWSAzureGCP) documentation.