“Notebook does not exist” error when trying to open a notebook

Create notebooks in a personal folder and keep backups of notebooks. If the notebook is in a Git repo’s commit history, restore from a previous commit.

Written by umakanth.charakanam

Last published at: October 28th, 2025

Problem

You intermittently encounter an error when attempting to open notebooks in your workspace.

Notebook does not exist. The specified notebook was not found. Double check the URL to make sure you're accessing a valid notebook.

 

You notice the error occurs even if you recently accessed or are actively working on the notebook. 

 

Cause

The notebook was either deleted or overwritten. 

 

The notebook could have been manually deleted from the Databricks workspace directly (including from the trash). When you try to access the notebook directly using its URL, the error occurs. 

 

If the notebook is part of a Databricks repo linked to a Github repo and is deleted from Github, a subsequent git pull within Databricks permanently removes the notebook from your Databricks workspace. 

 

If a new notebook is created in a Databricks repo but not committed to the linked GitHub repo, and a git pull is performed, a merge conflict can occur. Resolving this conflict in a way that overwrites or discards the local, uncommitted notebook deletes it from the workspace, resulting in the error.

 

Solution

There are two preventative measures you can take and one recovery measure if the deleted notebook is in a Github repo’s commit history.

  1. Create notebooks in your personal user folder instead of a shared folder to restrict access by default. You can grant permissions to other users as needed.
  2. Maintain a backup copy of notebooks you work with in your workspace.
  3. Check the GitHub repo's commit history to see if the deleted notebook exists in a previous commit. If so, you can restore the notebook by reverting to that commit and then performing a git pull in Databricks to sync the changes.