Problem
Your metastore admin group was accidentally deleted from your Databricks account. The same group owned your Unity Catalog and underlying schemas. As a result, you lost access to the catalogs and schemas.
Cause
Once a group is deleted, it cannot be restored. Any associated permissions for the group and/or its users are removed. If the metastore admin entity is deleted, access to the catalogs and schemas is permanently lost.
Solution
If the group was fully deleted (from both the Databricks account console and from your SCIM provider), you must recreate it.
If the group was only deleted from the Databricks account console, sync the desired group from your SCIM provider (AWS | Azure | GCP).
After the group has been recreated (or synced):
- Assign the group as the metastore admin in the Databricks account console.
- Add yourself to the group.
- Run
ALTER CATALOG
command to update the ownership of the desired catalogs under the metastore to the newly created/synced metastore admin group. - Add the desired users to the group.
Info
If you are using Microsoft Entra ID as your SCIM provider and the users in the group are not synced with the initial SCIM sync, you can request an immediate sync (AWS | Azure | GCP).